Scheduled Infrastructure & Systems Upgrade – In Progress...

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 12:32 AST

Identified

estudiodetitulo.net is down for a maintenance and full website upgrade.
Posted Jul 09, 2026 - 05:30 AST
This incident affected: Core Infrastructure, Web Platforms, and Business Operations.